Support Knowledge Center

Support Article

Back to search

Prepopulation doesn't work in 7.4.1


Article Number: 000001544
Published: December 21, 2016
When started Prepopulation in 7.4.1, it doesn't work and respond “Failure, Operation now in progress”
In version 7.4.1, when a prepopulation operation is started, instead of completing successfully, the following errors are shown in the log:

kernel: [878120.496556] CIFS VFS: Error connecting to socket. Aborting operation.
kernel: [878120.496639] CIFS VFS: cifs_mount failed w/return code = -115
prepopd[8083]: [prepopd.NOTICE]: PrepopD error: Failure, Operation now in progress
The prepopulation failed when selected only one bridge to associate with one circuit.

To verify:
1. Ensure the path to the CIFS server is correct, and is it pingable from Exinda to the server.
2. Make sure when adding prepopulation, the username and password are correct and the user with those credentials is allowed to access the folder.
3. Verify that the optimizer is turned on. It needs to be turned on before prepopulation is enabled.
4. When starting prepopulation, if it shown “Failure, Operation now in progress on the page of prepopulation” on the GUI page, and in the logs, the following errors were generated:
  • kernel: [878120.496556] CIFS VFS: Error connecting to socket. Aborting operation.
  • kernel: [878120.496639] CIFS VFS: cifs_mount failed w/return code = -115
  • prepopd[8083]: [prepopd.NOTICE]: PrepopD error: Failure, Operation now in progress
5. Go to optimizer page and check the circuit configuration. Is the circuit associated with only one bridge or ALL?
There are 2 options to make prepopulation works normally as interim solutions. Both work in various scenarios, but will perform the same task.
  1. Go to the optimizer and associate the circuit to ALL bridges. All of the virtual circuits and policies belonging to this circuit will apply to all bridges after this, not just the bridge originally specified (if there are multiple circuits for multiple bridges, a configuration rework might be necessary)
 User-added image

       2. Enable Global QoS under Configuration > System > Setup > Control. This will aggregate the bridges into one 'logical' bridge from the Exinda's perspective. For more information, see the information about global control in KB 1606.
This problem has been fixed in 7.4.4. Please upgrade to 7.4.4 and verify. If the issue persists, please contact Exinda Support for assistance.
 
D-05502